[winswitch] xpra shadow works, but start-desktop just shows a black screen

Ben Sferrazza Benjamin.Sferrazza at skyworksinc.com
Thu Apr 18 00:25:24 BST 2019

On Wed, 2019-04-17 at 15:23 -0700, Ben Sferrazza wrote:
On Mon, 2019-04-15 at 23:57 +0000, Ben Sferrazza via shifter-users
On 12/04/2019 21:33, Ben Sferrazza via shifter-users wrote:
On 12/04/2019 05:47, Ben Sferrazza via shifter-users wrote:
I'm running Xpra 2.5 from the Xpra repo on Ubuntu 18.10. The
client is Xpra 3.0 on Windows 10. Using 'xpra shadow' works
well, but I can't get 'xpra start-desktop' to work. It merely
shows a black screen.
xpra start-desktop on its own will only start an empty full-
session, you need to start a window manager or some other
application to
interact with, ie for testing:
xpra start-desktop --start=xterm
Then you can start a window manager or something else from the
I'm sorry, I should have mentioned I used --start=gnome-session.
Well, there is your problem.
Try a different window manager, or as per above just an xterm, and
will find that things work just fine.
gnome is known to be problematic and may not work without an
X11 server.

Using xfce4 instead of gnome seems to work well. I'm satisfied with
that as a solution. The only issue is that I'd like to run 'xpra start-
desktop' as a service so that I may be able to remotely login into that
session even if my computer were to unexpectedly restart while I'm out
of the office. It would also allow me to use the same work PC that Xpra
is run on and attach to it locally, treating that Xpra desktop as my
main session whether local or remote. I figured this might be a common
use case, but didn't find any info regarding using it as a service,
much as one would do with a headless Linux VNC setup.

I tried following much of the ArchLinux wiki, without success. This is
still being run on Ubuntu 18.10.

Here's an xpra at .service I created under /etc/systemd/system:

Description=Xpra Remote Desktop
After=syslog.target network.target nfs-home.mount

ExecStart=/usr/bin/xpra --no-daemon start-desktop --start=startxfce4


And the /etc/conf.d/xpra:


I enabled the service by using 'systemctl enable
xpra at myusername.service<mailto:xpra at myusername.service>'

Still not working, but I do see the xpra process running after logging into my Linux box locally. Just cannot attach to it. Reports that it doesn't detect any live xpra sessions.

myuserna+  2554  1.4  0.6 466784 110644 ?       SLs  16:15   0:04 /usr/bin/python2 /usr/bin/xpra --no-daemon start-desktop --start=startxfce4 :2

myuserna+  2794  1.1  1.2 1104644 197308 ?      Ssl  16:15   0:03 /usr/lib/xorg/Xorg-for-Xpra-:2 -noreset -novtswitch -nolisten tcp +extension GLX +extension RANDR +extension RENDER -auth /home/myusername/.Xauthority -logfile /tmp/Xorg.:2.log -configdir /run/user/10345/xpra/xorg.conf.d/2554 -config /etc/xpra/xorg.conf -depth 24 :2

The Xorg.:2.log shows a couple of errors that occurred when it started as a service.

[    51.003] (EE) Unable to locate/open config directory: "/run/user/10345/xpra/xorg.conf.d/2554"

[    51.487] (EE) systemd-logind: failed to get session: PID 2794 does not belong to any known session

Thanks for any advice on how to debug this issue.


More information about the shifter-users mailing list