[winswitch] Downgrading xpra

Wolfram Humann direkt1 at wolframhumann.de
Thu Aug 1 15:36:45 BST 2019


Thanks for your reply. Some observations:
1. I managed to install 1.0.13 doing "sudo yum --releasever=7.1 install
xpra" (had to manually install python-crypto before it would work but
that's all)
I had tried something similar before editing winswitch.repo and replacing
"baseurl=http://winswitch.org/dists/CentOS/$releasever/$basearch/" with
"baseurl=http://winswitch.org/dists/CentOS/7.1/$basearch/" but to my
surprise yum still wanted to install version 2.5.3 (and failed as mentioned
before when I tried to force yum to install 1.0.13)

2. I have a Konsole window receiving lots of output from a program and
therefore scrolling fast. In 1.0.13 there is no problem with that. In 2.5.3
it always hangs a bit between screen updates. Also in 2.5.3 I sometimes
receive messages about my connection being slow with some options what to
do about it. I've never seen those in 1.0.13

3. In 2.5.3 when I have menus hitting the bottom of the screen, I will have
a vertical offset between the mouse-pointer and the selected entry (see
attached screenshots -- the mouse pointer is 6-7 entries higher than the
selection). That does not happen in 1.0.13. It might be worth mentioning
that I have an (unusual?) setup of one horizontal (main) monitor and one
vertical on the left, so there are screen coordinates on the left monitor
extending below and above the main screen.

If you have any suggestions, I can go back to 2.5.3. and try them out. But
I will be on vacation for one week starting tomorrow, so I would do that
afterwards.

Thanks for maintaining and supporting this nice and very useful piece of
software!
Wolfram


More information about the shifter-users mailing list