[winswitch] Start-desktop black screen and Shadow crashes on Ubuntu 18.04

Antoine Martin antoine at nagafix.co.uk
Tue Apr 7 18:04:09 BST 2020


On 07/04/2020 22:58, Jake Black via shifter-users wrote:
> Greetings, 
> 
> I am trying to get xpra to show a full desktop on Ubuntu 18.04.3 (both client and server). I can successfully launch applications and they are stable. However, when I try to use "start-desktop", xpra launches, but just shows a black screen and I cannot interact with it.
You need to start a window manager. ie:
xpra start-desktop \
   --start-child=fluxbox --exit-with-children \
   --attach=yes

Or an xterm and you can try starting your window manager from there.

> However, I can launch a desktop with lxsession. But I would really like to have a gnome session.
On Fedora 31, using --start=gnome-session, I get the dreaded "oh no,
something went wrong dialog" but after dismissing it the session is
actually perfectly usable.
On Ubuntu 18.04 and 19.10, it just does not work at all.
Perhaps GNOME requires OpenGL acceleration to work properly?
(since I couldn't find a virtualgl package for Ubuntu, I didn't try this
potential workaround)

Generally speaking, when displaying things remotely via xpra, you're
much better off running a lightweight desktop like fluxbox than a heavy
one like GNOME or KDE.

> When I close the window, the following error is printed: 
> 
> /usr/lib/python3/dist-packages/xpra/client/gtk_base/gtk_client_base.py:150: Warning: g_object_ref: assertion 'G_IS_OBJECT (object)' failed 
> gtk_main() 
This is completely unrelated and you can safely ignore this message.

> From what I have found this is a pretty generic error and doesn't point to one thing. 
Correct.

> When I try to connect to an existing xsession with "shadow", the remote screens open, but when I interact with it by clicking in the window, they just close, "connection lost" is printed, the physical xsession crashes,
Do you mean the xpra server? (not the local X11 session)

> and the following error is printed in /run/user/[uid]/xpra/:1.log: 
> 
> Gdk-Message: 10:12:32.098: Xpra: Fatal IO error 11 (Resource temporarily unavailable) on X server :1. 
That's usually a sign that the X11 server has crashed.

I've just quickly tried shadowing 18.04 and 19.10 test systems, and I am
not seeing any crashes or other obvious bugs.
I suspect that there must be something different with your system.
Please make sure that you're running the latest official version.

> I have found the following mailing list message that sounds familiar 
> [ http://lists.devloop.org.uk/pipermail/shifter-users/2018-October/002231.html | http://lists.devloop.org.uk/pipermail/shifter-users/2018-October/002231.html ] 
> 
> And points to the following ticket: 
> 
> [ https://xpra.org/trac/ticket/1981#comment:5 | https://xpra.org/trac/ticket/1981#comment:5 ] 
> 
> And here the issue is reported as a bug in Ubuntu packaging and that the issue was resolved by removing the "gtk3-nocsd" and "libgtk3-nocsd0" packages. I have confirmed that these packages do not exist on either my server or my client. 
That's unlikely to be related if you don't have gtk3-nocsd installed.
Please post the full details of your error, preferably in a new ticket.
> 
> Additionally I have tried disabling opengl and using native opengl and the result does not change. 

Cheers,
Antoine
> 
> 
> Thanks, 
> 
> Jake 
> _______________________________________________
> shifter-users mailing list
> shifter-users at lists.devloop.org.uk
> https://lists.devloop.org.uk/mailman/listinfo/shifter-users
> 



More information about the shifter-users mailing list