[winswitch] Discussion about https://xpra.org/trac/changeset/26090/xpra

Antoine Martin antoine at nagafix.co.uk
Sun Apr 12 07:34:11 BST 2020


On 12/04/2020 01:12, Σταύρος Ντέντος via shifter-users wrote:
> Hello Antoine,
> 
> Coffee-break discussion: I understand why you would maintain v2.[45], v3.x
> (thank you :-)) ...
V2.x are not LTS versions but v1.x is.

> Why on earth maintain v1.x? Is it some "smaller" version, supporting ages
> old systems ... what?
xpra v1.x was the last branch to support Python versions 2.6 and older,
which includes OSes like RHEL / CentOS 6.x
Like it or not, RHEL 6.x is going to be supported by RedHat until 2024
under the "Extended Lifecycle Support" schedule.

Preserving basic backwards compatibility is not that much of a
difficulty anyway.
That said, it is time to move on, and the next 1.x stable update is
likely to be the last.

Cheers,
Antoine



> 
> With regards,
> Ntentos Stavros
> _______________________________________________
> shifter-users mailing list
> shifter-users at lists.devloop.org.uk
> https://lists.devloop.org.uk/mailman/listinfo/shifter-users
> 



More information about the shifter-users mailing list