[winswitch] Focus issue

Antoine Martin antoine at nagafix.co.uk
Fri Apr 17 16:16:08 BST 2020


On 17/04/2020 19:26, carl langlois wrote:
> Hi,
> When it happen all the windows seems to be affected. It seem that all
> the. It look to me that some windows(application) grab the focus and all
> the other application does not received even.
Please see --modal-windows=no
A modal window will stay on top of all other windows unless you turn off
this feature.
> I can currently easily reproduce the situation where a windows freeze (i
> suspect a application bugs) . It seem that in this case the application
> enter a weird state and freeze all other application managed by Xpra.
> Even new application started from the tray menu are not responding to
> the mouse.
Unless the server eventually disconnects, this sounds like a modal
window or a grab.

> if i ssh to the workstation and kill the application everything is start
> working again. I think this particular problem is coming from a bad
> behavior of Rabbitvcs.. I am not a expert in this kind of software but
> the fact that all the windows are frozen seems wrong.
Could be, it could also be a bug in xpra.
> Not sure how to tackle this situation. Not related to java application
> and i have seen this behavior with other perl/tk application,
> dophin file manager etc. 
I've just tried it in an Ubuntu 19.10 virtual machine and I couldn't see
any obvious problems.
Do I have to use a specific dialog or action to trigger this bug?

Assuming that this isn't a modal window problem, would you mind creating
a ticket for this problem?

Thanks,
Antoine


> Carl.
> 
> 
> 
> 
> On Fri, Apr 17, 2020 at 2:55 AM Antoine Martin via shifter-users
> <shifter-users at lists.devloop.org.uk
> <mailto:shifter-users at lists.devloop.org.uk>> wrote:
> 
>     On 17/04/2020 00:35, carl langlois via shifter-users wrote:
>     > Hi,
>     >
>     > Using 3.0.9 on both server(Ubuntu 19.10) and client(windows 10)
>     the mouse
>     > does not seem to click at the good location. Like if all focus is
>     wrong
>     > between the windows and the mouse.
>     Is this with all applications or just a specific one? For all its
>     windows, or maybe just popup menus?
>     Does it not work with a plain xterm, or maybe your window is maximized?
>     If the offset large or small? Are you using Wayland client-side perhaps?
> 
>     There are a number of tickets related to pointer offsets, but they
>     generally involve Java or proprietary applications. Here's a ticket
>     which may be related:
>     http://xpra.org/trac/ticket/2600
>     If this is the right place, please add your information there.
> 
>     Cheers,
>     Antoine
> 
> 
>     >
>     > Thanks and Regards
>     >
>     > Carl
>     > _______________________________________________
>     > shifter-users mailing list
>     > shifter-users at lists.devloop.org.uk
>     <mailto:shifter-users at lists.devloop.org.uk>
>     > https://lists.devloop.org.uk/mailman/listinfo/shifter-users
>     >
> 
>     _______________________________________________
>     shifter-users mailing list
>     shifter-users at lists.devloop.org.uk
>     <mailto:shifter-users at lists.devloop.org.uk>
>     https://lists.devloop.org.uk/mailman/listinfo/shifter-users
> 



More information about the shifter-users mailing list