[winswitch] Key repeat bug

Anthony Stone ajs1 at cam.ac.uk
Fri Apr 2 16:23:41 BST 2021


Sorry, I forgot to say: Ubuntu 18.04 and xpra 4.1.1 on client and server.

I have tried turning keyboard sync off, and so far have had no more 
trouble, but that hasn't been very long. Is it reasonable to leave it 
off indefinitely?

It's a fast broadband connection, approaching 100 mb/s. The ping time to 
the server is around 24 ms.

Regards,
Anthony

On 01/04/2021 18:00, Antoine Martin via shifter-users wrote:
> On 01/04/2021 23:18, Anthony Stone via shifter-users wrote:
>> Hello,
>>
>> I'm experiencing odd behaviour while using xpra. Quite often, when I
>> press a key, however briefly, the character seems to be transmitted many
>> times -- as many as 20 times or more. This happens both when working in
>> emacs on the remote machine, and also, less often, on the command line
>> of the remote. It happens to many different characters, including return
>> and backspace  (delete), so I don't think it can be a sticky keyboard.
>> Can it be a bug in xpra? It happens often enough in emacs to be a real
>> nuisance.
> What version and OS are you using on client and server?
> 
> Have you tried turning keyboard-sync off?
> What is the latency of your connection?
> 
> Cheers,
> Antoine
> 
>>
>> Anthony
>> _______________________________________________
>> shifter-users mailing list
>> shifter-users at lists.devloop.org.uk
>> https://lists.devloop.org.uk/mailman/listinfo/shifter-users
> 
> _______________________________________________
> shifter-users mailing list
> shifter-users at lists.devloop.org.uk
> https://lists.devloop.org.uk/mailman/listinfo/shifter-users
> 


More information about the shifter-users mailing list