[winswitch] Black windows with Xpra, Docker and WIne

Craig Setera craigjunk at setera.org
Thu Aug 5 02:12:37 BST 2021


I'm in the midst of trying to get the Fitbit Simulator which is only 
supported on Windows and MacOS using my Linux (Ubuntu latest) laptop.  
While I started with 
https://github.com/bingtimren/fitbit-simulator-linux-wine-image, I had 
issues with the fact that my laptop is actually a HiDPI machine and the 
resulting application was much too small.  I remembered that I had seen 
an example of using Xpra to scale a Linux desktop application and 
decided to see if I could do the same with this.  I set up a Docker 
container to bind Xpra to a TCP Port and am attaching to that port from 
the host port.

Unfortunately, I'm getting very inconsistent results.  When it works, 
things are properly scaled (by 2x) and work as I would expect.  However, 
many times, I end up with a completely black window.  I've tried many 
different combinations of options on both the container (server) side 
and the attach side.  I've tried to disable as much functionality as 
possible as well.  In the end, I'm just not getting a consistent 
non-black display.

Can anyone suggest how to troubleshoot this issue?  The fact that it 
seems to work sometimes makes me feel like I'm close to a solution.



More information about the shifter-users mailing list