[winswitch] xpra launcher: connectionn fails with no message

Eric Levy contact at ericlevy.name
Mon Dec 13 12:10:33 GMT 2021


I am running Linux Mint 20.2 on both a server and client system, with
Xpra versions 4.2.3-r12 (server) and xpra v4.3-r30655 (g1e8a46dce)
(client). I have also tried the 4.2.3 release on the client, with no
noticeable difference respecting my problem.

Until recently, I could connect either through the graphical launcher
or the command-line client. However, presently, the laucher invariably
fails to connect. No error dialog box appears, or other useful
indication of a problem. The connection window simply drops at some
point after the password prompt. From the command line, however, the
issue does not present. Connection is successful, and I see no
worrisome messages among the console output.

Previously, both methods had worked. Recently, the server was restored
from backup, to a different VM in the same hypervisor. The only
difference might be certain unique identifiers, such as MAC address or
disk partition UUIDs.

I cannot find any log files that might help discover a problem reported
by the graphical launcher client. I have looked in ~/.xpra and
~/.settings/xpra on both server and client.

Where might I look for an indication of the source of the problem? What
suggestions might anyone offer to resolve?

Thank you for your help.

More information about the shifter-users mailing list