[winswitch] xpra launcher: connectionn fails with no message

Antoine Martin antoine at nagafix.co.uk
Wed Dec 15 13:15:26 GMT 2021

On 13/12/2021 19:10, Eric Levy via shifter-users wrote:
> Hello.
> I am running Linux Mint 20.2 on both a server and client system, with
> Xpra versions 4.2.3-r12 (server) and xpra v4.3-r30655 (g1e8a46dce)
> (client). I have also tried the 4.2.3 release on the client, with no
> noticeable difference respecting my problem.
There have been a number of bugs reported recently with ssh connections:

Perhaps it is one of those?
I would have expected the 4.3-r30655 client to include this fix though.

> Until recently, I could connect either through the graphical launcher
> or the command-line client. However, presently, the laucher invariably
> fails to connect. No error dialog box appears, or other useful
> indication of a problem. The connection window simply drops at some
> point after the password prompt. From the command line, however, the
> issue does not present. Connection is successful, and I see no
> worrisome messages among the console output.
> Previously, both methods had worked. Recently, the server was restored
> from backup, to a different VM in the same hypervisor. The only
> difference might be certain unique identifiers, such as MAC address or
> disk partition UUIDs.
> I cannot find any log files that might help discover a problem reported
> by the graphical launcher client. I have looked in ~/.xpra and
> ~/.settings/xpra on both server and client.
xpra launcher --debug ssh
The command output will include all ssh connection messages.
(I assume that you're using ssh to connect - please include the command 
lines if that is not the case)

> Where might I look for an indication of the source of the problem? What
> suggestions might anyone offer to resolve?
I would try the command line above whilst keeping an eye on your 
server's ssh log file.


> Thank you for your help.

More information about the shifter-users mailing list