[winswitch] This server does not export any commands and No users

Antoine Martin antoine at nagafix.co.uk
Sat Dec 1 07:27:37 GMT 2012


On 12/01/2012 11:12 AM, martin wrote:
> Hi all in the user list,
> The forum is giving me 500 errors or something. 
Yes, I know, sorry about that - I meant to fix that a long time ago,
just haven't got around to it.
Problem is that djangobb is very brittle and breaks regularly with each
python system library updates..
> Here is the related topic in google cache
> http://webcache.googleusercontent.com/search?q=cache:UCZz2MA-qykJ:https://winswitch.org/forum/post/44/+&cd=1&hl=en&ct=clnk
> Tried running the script from /usr/lib/winswitch/load_xsessions_test.py
> as root
> I get
> http://pastebin.com/cHNb0hBx

    [II] 2012/30/11 23:52:01.240689 load_xsessions_test.main()
    Desktop(GNOME: gnome-session)
    [II] 2012/30/11 23:52:01.240814 load_xsessions_test.main()
    Desktop(TWM: twm)

It found your desktop sessions alright.
> The connections seem to be running fine: Run from 'shodan' host
> Name Address Enabled Connected SSH
> asus-1201n yes yes yes
> shodan yes yes yes
> No problem here. Avahi works fine. Discovered servers pop up and ask for
> password. I enter username password. I can see the uptime values, debian
> version an all that stuff.
> Still when I click on server properties "NO USERS FOUND". I get this
> message from local or remote server.
Sounds like the same bug that was fixed recently with old debian/ubuntu
versions. (lucid?)
What distro and version are you running, have you tried the beta build I
> And also from remote or local servers I get
> "This server does not export any commands!"
> my winswitch boot sequence
> http://pastebin.com/4SHJ4bFg
[ee] 2012/01/12 00:40:34.804922 CannotListenError: Couldn't listen on
any:/home/martin/.winswitch/server/socket: [Errno 98] Address already in
> my server config
> http://pastebin.com/BxFG39FZ
As per above, try using a different port for the server.
It would be good to figure out why it cannot use the default one -
probably another instance running already.
> content from /usr/share/xsessions/gnome.desktop 
> http://pastebin.com/LGHt0LW8
> This is driving me nuts! 
> Xpra works fine if run by itself (at least connecting to localhost).
> I humbly thank everyone for their help.
Which version are you running? Have you tried the beta builds?

Also, please subscribe to the list so I don't have to manually accept your posts.

> smeagol271006 at gmail.com
> Martin
> _______________________________________________
> shifter-users mailing list
> shifter-users at lists.devloop.org.uk
> http://lists.devloop.org.uk/mailman/listinfo/shifter-users

More information about the shifter-users mailing list