[winswitch] Problems connecting between Fedora -> gentoo/OpenSUSE

Christopher Faylor me.xpra at cgf.cx
Wed Jan 30 22:33:07 GMT 2013

On Thu, Jan 31, 2013 at 03:45:12AM +0700, Antoine Martin wrote:
>On 01/31/2013 01:00 AM, Christopher Faylor wrote:
>> "808464432" is, in hex, "0x30303030".
>> I've tried using a direct TCP connection with similar results.
>> In case it matters, the Gentoo and OpenSUSE systems are on a local
>> network while the Fedora system is going over the internet.
>> If I downgrade the OpenSUSE version to 0.3.6-1, I can connect from
>> Fedora but not from Gentoo.
>Are you sure they are all the same versions, sounds like they are not.
>> I'd appreciate any hints on how to resolve this problem.
>First, v0.3 is unsupported and broken/insecure. Worst thing is that this
>is 0.3.6, so it's not even the latest from the old (and no longer
>supported) v0.3 branch. Do not use.

Sorry.  I should have made it clear that the reason I tried 0.3.6 was
because I was stepping back to see which version worked.

>Second, it looks to me like your Fedora box is not running 0.7.8, maybe
>some older version too.
>So, the simple answer is: run supported versions and everything should
>work fine, until then, I can't help you, sorry.

That was the hint I needed.  RPM did report 0.7.8 (I triple checked) but
apparently I had somehow had old stuff sitting around.  I found
xpra-related libraries sitting around in python locations.  Once I nuked
those, a reinstallation worked (I'm now on 0.8.0).

So, obviously I must have installed 0.3.something in some nonstandard
way and screwed up my system.

Thanks for the help.  Much appreciated.


More information about the shifter-users mailing list