[winswitch] BUG: Mouse pointer stops working in multi-/single display setup

Lukas Haase lukashaase at gmx.at
Tue Nov 18 19:11:02 GMT 2014

Hi Antoine,

> On 15/11/14 04:20, Lukas Haase wrote:
> > Hi,
> >
> > I observered the following bug in the latest xpra v0.14.11 which can be reproduced in exactly the same manner:
> (..)
> I believe you're hitting this bug which is high on my list:
> http://xpra.org/trac/ticket/349
> Feel free to subscribe to this ticket to help and be notified of fixes. (*)

Indeed, this sounds very similar.

I subscribed. Looking forward to a solution :)

> > Re-attaching does not help.
> > Restarting the X server at the client helped one single time but otherwise did not help.
> Below, you're saying that  your client is Windows 7.
> How can you restart the X server since there isn't one on MS Windows?
> Unless you're talking about the Cygwin X11 server - but I don't see how
> you would get an xpra build to use X11 on win32: xpra on MS Windows uses
> "native" GTK-win32.

Yes, I am talking about the Cygwin X11 Server. I.e., I just exit the server and restart the exe.

I don't use xpra natively on Windows. Here is what I do:

1.) On the server, in a screen session "xpra start", followed by "DISPLAY=:123 myapp"

2.) Using PuTTY/plink.exe, I connect to the same server and call "xpra attach"

I hope there is nothing wrong about it because I like the way it works: Just as ordinary X forwarding but better ;-)

I tried winswitch and some point but did not get it working and I found no good docu on it, so I sticked with this. But I didn't look to deep into it.

> > Using "xpra upgrade" on the server seems to help.
> >
> > system configuration:
> >
> > Server: CentOS 6 with official repository (xpra v0.14.11)
> > Client: Windows 7, Cygwin SSH server, connection over SSH + Forwarding.
> I assume you mean Cygwin SSH client here?

I am actually using Putty/plink.exe with X forwarding.

> Can you paste the command line that you use for connecting? (I can't
> remember the last time I tried to use xpra with Cygwin's ssh instead of
> plink - good to know it still works)

I just use (this is in my connect.cmd):

    plink.exe -X -load "my-remote-server" "~/xpra_client.sh"

where my-remote-server is just a stored PuTTY session.

xpra_client.sh on the server just contains:

    xpra attach :1984 --no-keyboard-sync --encoding=rgb


More information about the shifter-users mailing list