[winswitch] xpra shadow works, but start-desktop just shows a black screen

Antoine Martin antoine at nagafix.co.uk
Fri Apr 12 04:45:23 BST 2019

On 12/04/2019 05:47, Ben Sferrazza via shifter-users wrote:
> I'm running Xpra 2.5 from the Xpra repo on Ubuntu 18.10. The client is Xpra 3.0 on Windows 10. Using 'xpra shadow' works well, but I can't get 'xpra start-desktop' to work. It merely shows a black screen.
xpra start-desktop on its own will only start an empty full-window
session, you need to start a window manager or some other application to
interact with, ie for testing:
xpra start-desktop --start=xterm
Then you can start a window manager or something else from the xterm.

> Similarly, trying to just launch a window such as 'xpra start=gnome-terminal' shows nothing. 'xpra start=xterm' does bring up xterm, but trying to launch something like gnome-terminal from that xterm shows nothing. Verbose logs don't seem to indicate anything is amiss.
> Any advice on things I can try?
That's odd. I've just tried it and it worked fine.
Please create a ticket as per:
Make sure to include "xpra info".
And please try connecting from another client (ie: from the Ubuntu
system itself) to figure out if the problem is server side or client side.


> Thanks,
> Ben
> _______________________________________________
> shifter-users mailing list
> shifter-users at lists.devloop.org.uk
> https://lists.devloop.org.uk/mailman/listinfo/shifter-users

More information about the shifter-users mailing list