[winswitch] XPRA via SSH proxy problem

Antoine Martin antoine at nagafix.co.uk
Mon Aug 5 17:47:23 BST 2019

On 05/08/2019 23:17, Kane, Daniel via shifter-users wrote:
> Hello all,
> I have tested the following from both OSX 10.14.4 and Fedora 30 both using xpra v2.5.3-r23271 , with identical results :
> xpra start ssh:user at proxied_host --start=xterm
> where my .ssh/config has a ProxyCommand entry for proxied_host (this works fine, I can ssh directly to user at proxied_host)
> …yet the final error I see in the output is:
> 2019-08-05 12:14:31,395 xpra initialization error: _proxy_start: expected 1 argument but got 0: []
> 2019-08-05 12:14:31,408 Connection lost
This looks like a bug.

> Is there any more information I could provide to help figure this out?
Can you provide a minimal test case?
I've just tried it with this entry in my .ssh/config:
Host test
  ProxyCommand ssh -v localhost nc 22

And this command worked fine:
xpra start ssh://test/ --start=xterm -d ssh

The "-d ssh" should give you more details about what is going on.
It may be that your configuration is incompatible with the paramiko
backend, in which case you should be able to revert to openssh with
xpra --ssh="ssh -x"
But I would prefer figuring out what the problem is and fixing it.


> All the best,
> Dan
> _______________________________________________
> shifter-users mailing list
> shifter-users at lists.devloop.org.uk
> https://lists.devloop.org.uk/mailman/listinfo/shifter-users

More information about the shifter-users mailing list